Quantcast

Invoke and assertions & Perl ?

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Invoke and assertions & Perl ?

Kämpfe, Christiane
 
Hello,
 
I have seen that there was a topic #33 concerning an assertion failure for Phyton.
 
In my test I can see this for Perl binding
 
perl: u/hash.c:724: ow_hash_scan_delete: Assertion `ow_hash_lookup(hash, node->hash_key) == node' failed.
 
Question 1
        Is this problem solved with V2.4.8 ?
Question 2
        which rpm must be replaced with new version ?
                libwsman1, wsmancli, openwsman-perl
Question 3
        Where can I and future customers find rpms for SLES and RedHat ?
        (I think I have seen something for OpenSUSE)
 
Another question
        Is wsman executable able to invoke methods where selectors and arguments are required ?
        ( there was discussion-thread at one time )
 
Thanks for any suggestion
 
 
 
 

------------------------------------------------------------------------------

_______________________________________________
Openwsman-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openwsman-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Invoke and assertions & Perl ?

Klaus Kaempf
* Kämpfe, Christiane <[hidden email]> [Oct 27. 2014 09:24]:

>
> Hello,
>
> I have seen that there was a topic #33 concerning an assertion failure for Phyton.
>
> In my test I can see this for Perl binding
>
> perl: u/hash.c:724: ow_hash_scan_delete: Assertion `ow_hash_lookup(hash, node->hash_key) == node' failed.
>
> Question 1
>         Is this problem solved with V2.4.8 ?

Yes, the respective commit is part of 2.4.8

> Question 2
>         which rpm must be replaced with new version ?
>                 libwsman1, wsmancli, openwsman-perl

All of them.

> Question 3
>         Where can I and future customers find rpms for SLES and RedHat ?
>         (I think I have seen something for OpenSUSE)

openwsman is part of SLES, which comes with full support.
I believe openwsman is also part of RHEL, but don't know for sure.

Community-supported packages for various distributions can be found at
https://build.opensuse.org/project/show/Openwsman

>
> Another question
>         Is wsman executable able to invoke methods where selectors and arguments are required ?
>         ( there was discussion-thread at one time )

wsman exposes many client API functions but not all of them. For full
access to the wsman client API, please use C, Python, Ruby, Perl, or
Java.


Klaus
--
SUSE LINUX Products GmbH, GF: Jeff Hawn, Jennifer Guild, Felix Imendörffer, HRB 16746 (AG Nürnberg)
Maxfeldstraße 5, 90409 Nürnberg, Germany

------------------------------------------------------------------------------
_______________________________________________
Openwsman-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openwsman-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Invoke and assertions & Perl ?

Kämpfe, Christiane
Hello,

thank you for the answer. We will add the link you mentioned in our documentation because
RH and SLES come up with older versions (some with 2.2.* some with 2.3.* - newest version found 2.4.6).

Concerning wsman invoke I have started to write a helper Perl-Script and the colleagues which wanted to use wsman directly
must then use my script.

-ckae

-----Original Message-----
From: Klaus Kaempf [mailto:[hidden email]]
Sent: Tuesday, October 28, 2014 4:34 PM
To: Kämpfe, Christiane
Cc: [hidden email]
Subject: Re: [Openwsman-devel] Invoke and assertions & Perl ?

* Kämpfe, Christiane <[hidden email]> [Oct 27. 2014 09:24]:

>
> Hello,
>
> I have seen that there was a topic #33 concerning an assertion failure for Phyton.
>
> In my test I can see this for Perl binding
>
> perl: u/hash.c:724: ow_hash_scan_delete: Assertion `ow_hash_lookup(hash, node->hash_key) == node' failed.
>
> Question 1
>         Is this problem solved with V2.4.8 ?

Yes, the respective commit is part of 2.4.8

> Question 2
>         which rpm must be replaced with new version ?
>                 libwsman1, wsmancli, openwsman-perl

All of them.

> Question 3
>         Where can I and future customers find rpms for SLES and RedHat ?
>         (I think I have seen something for OpenSUSE)

openwsman is part of SLES, which comes with full support.
I believe openwsman is also part of RHEL, but don't know for sure.

Community-supported packages for various distributions can be found at https://build.opensuse.org/project/show/Openwsman

>
> Another question
>         Is wsman executable able to invoke methods where selectors and arguments are required ?
>         ( there was discussion-thread at one time )

wsman exposes many client API functions but not all of them. For full access to the wsman client API, please use C, Python, Ruby, Perl, or Java.


Klaus
--
SUSE LINUX Products GmbH, GF: Jeff Hawn, Jennifer Guild, Felix Imendörffer, HRB 16746 (AG Nürnberg) Maxfeldstraße 5, 90409 Nürnberg, Germany
------------------------------------------------------------------------------
_______________________________________________
Openwsman-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openwsman-devel
Loading...