openwsman-perl package for Ubuntu

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

openwsman-perl package for Ubuntu

Swapnil_Shivhare

Hi,

 

I have build and made openwsman-perl package for Ubuntu (both i386 and x86_64) in debain format. This package is missing in the download repository Ubuntu.

I want to upload this in the repository http://download.opensuse.org/repositories/ . Can you please tell me the procedure as how can I make this contribution.

 

Thanks,

Swapnil


------------------------------------------------------------------------------

_______________________________________________
Openwsman-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openwsman-devel
Reply | Threaded
Open this post in threaded view
|

Re: openwsman-perl package for Ubuntu

Klaus Kaempf
* [hidden email] <[hidden email]> [Nov 07. 2014 12:12]:
> Hi,
>
> I have build and made openwsman-perl package for Ubuntu (both i386 and x86_64) in debain format. This package is missing in the download repository Ubuntu.

That's great new, thanks !

> I want to upload this in the repository http://download.opensuse.org/repositories/ . Can you please tell me the procedure as how can I make this contribution.

Sign in to https://build.opensuse.org, send me your username, and I'll
add you to
https://build.opensuse.org/package/show/Openwsman/openwsman-deb
where the current Debian packages are hosted.

Klaus
--
SUSE LINUX GmbH, GF: Jeff Hawn, Jennifer Guild, Felix Imendörffer, HRB 21284 (AG Nürnberg)
Maxfeldstraße 5, 90409 Nürnberg, Germany

------------------------------------------------------------------------------
_______________________________________________
Openwsman-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openwsman-devel
Reply | Threaded
Open this post in threaded view
|

Re: openwsman-perl package for Ubuntu

Swapnil_Shivhare

Hi Klaus,

 

Sure, I’m testing it with various versions of Ubuntu after that I’ll upload it. I have a question about openwsman-perl package. Is it bound to any specific version of perl?

When I see the RHEL rpm,

 

/usr/lib/perl5/vendor_perl/5.8.8/openwsman.pm

/usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/openwsman.so

 

It looks bound to perl 5.8.8.  I have both perl5.8.8 and perl 5.14.4 on my rhel system. I am able to run my perl code with perl5.8.8 but not with perl5.14.4. I get segmentation fault when I execute it with perl5.14.4.

Please let me know.

 

Thanks,

Swapnil

-----Original Message-----
From: Klaus Kaempf [mailto:[hidden email]]
Sent: Friday, November 07, 2014 4:49 PM
To: Shivhare, Swapnil
Cc: [hidden email]; [hidden email]
Subject: Re: [Openwsman-devel] openwsman-perl package for Ubuntu

* [hidden email] [Nov 07. 2014 12:12]:
> Hi,
>
> I have build and made openwsman-perl package for Ubuntu (both i386 and x86_64) in debain format. This package is missing in the download repository Ubuntu.

That's great new, thanks !

> I want to upload this in the repository http://download.opensuse.org/repositories/ . Can you please tell me the procedure as how can I make this contribution.

Sign in to https://build.opensuse.org, send me your username, and I'll add you to https://build.opensuse.org/package/show/Openwsman/openwsman-deb
where the current Debian packages are hosted.

Klaus
--
SUSE LINUX GmbH, GF: Jeff Hawn, Jennifer Guild, Felix Imendörffer, HRB 21284 (AG Nürnberg) Maxfeldstraße 5, 90409 Nürnberg, Germany


------------------------------------------------------------------------------
Comprehensive Server Monitoring with Site24x7.
Monitor 10 servers for $9/Month.
Get alerted through email, SMS, voice calls or mobile push notifications.
Take corrective actions from your mobile device.
http://pubads.g.doubleclick.net/gampad/clk?id=154624111&iu=/4140/ostg.clktrk
_______________________________________________
Openwsman-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openwsman-devel
Reply | Threaded
Open this post in threaded view
|

Re: openwsman-perl package for Ubuntu

Klaus Kaempf
* [hidden email] <[hidden email]> [Nov 12. 2014 05:29]:
> Hi Klaus,
>
> Sure, I'm testing it with various versions of Ubuntu after that I'll upload it. I have a question about openwsman-perl package. Is it bound to any specific version of perl?

Well, it's bound to the Perl version the package was build with.
What is the official Perl version for RHEL ?

>
> It looks bound to perl 5.8.8.  I have both perl5.8.8 and perl 5.14.4 on my rhel system. I am able to run my perl code with perl5.8.8 but not with perl5.14.4. I get segmentation fault when I execute it with perl5.14.4.

Segfaults shouldn't happen. Please report it via
https://github.com/Openwsman/openwsman/issues
with full logs and a description to reproduce the crash.


Klaus
--
SUSE LINUX GmbH, GF: Jeff Hawn, Jennifer Guild, Felix Imendörffer, HRB 21284 (AG Nürnberg)
Maxfeldstraße 5, 90409 Nürnberg, Germany

------------------------------------------------------------------------------
Comprehensive Server Monitoring with Site24x7.
Monitor 10 servers for $9/Month.
Get alerted through email, SMS, voice calls or mobile push notifications.
Take corrective actions from your mobile device.
http://pubads.g.doubleclick.net/gampad/clk?id=154624111&iu=/4140/ostg.clktrk
_______________________________________________
Openwsman-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openwsman-devel
Reply | Threaded
Open this post in threaded view
|

Re: openwsman-perl package for Ubuntu

Swapnil_Shivhare

Dell - Internal Use - Confidential

The official perl version with RHEL5.8.8. But my application requires perl5.14 onwards. That’s why I am facing this issue. Is there a way I can make it work perl5.14 with openwsman-perl.

-----Original Message-----
From: Klaus Kaempf [mailto:[hidden email]]
Sent: Wednesday, November 12, 2014 1:37 PM
To: Shivhare, Swapnil
Cc: [hidden email]
Subject: Re: [Openwsman-devel] openwsman-perl package for Ubuntu

* [hidden email] [Nov 12. 2014 05:29]:
> Hi Klaus,
>
> Sure, I'm testing it with various versions of Ubuntu after that I'll upload it. I have a question about openwsman-perl package. Is it bound to any specific version of perl?

Well, it's bound to the Perl version the package was build with.
What is the official Perl version for RHEL ?

>
> It looks bound to perl 5.8.8. I have both perl5.8.8 and perl 5.14.4 on my rhel system. I am able to run my perl code with perl5.8.8 but not with perl5.14.4. I get segmentation fault when I execute it with perl5.14.4.

Segfaults shouldn't happen. Please report it via https://github.com/Openwsman/openwsman/issues
with full logs and a description to reproduce the crash.


Klaus
--
SUSE LINUX GmbH, GF: Jeff Hawn, Jennifer Guild, Felix Imendörffer, HRB 21284 (AG Nürnberg) Maxfeldstraße 5, 90409 Nürnberg, Germany


------------------------------------------------------------------------------
Comprehensive Server Monitoring with Site24x7.
Monitor 10 servers for $9/Month.
Get alerted through email, SMS, voice calls or mobile push notifications.
Take corrective actions from your mobile device.
http://pubads.g.doubleclick.net/gampad/clk?id=154624111&iu=/4140/ostg.clktrk
_______________________________________________
Openwsman-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openwsman-devel
Reply | Threaded
Open this post in threaded view
|

Re: openwsman-perl package for Ubuntu

Klaus Kaempf
* [hidden email] <[hidden email]> [Nov 12. 2014 09:39]:
> Dell - Internal Use - Confidential
> The official perl version with RHEL5.8.8. But my application requires perl5.14 onwards. That's why I am facing this issue. Is there a way I can make it work perl5.14 with openwsman-perl.
>

Compile openwsman with perl 5.14 installed, this could fix the issue.

Klaus
--
SUSE LINUX GmbH, GF: Jeff Hawn, Jennifer Guild, Felix Imendörffer, HRB 21284 (AG Nürnberg)
Maxfeldstraße 5, 90409 Nürnberg, Germany

------------------------------------------------------------------------------
Comprehensive Server Monitoring with Site24x7.
Monitor 10 servers for $9/Month.
Get alerted through email, SMS, voice calls or mobile push notifications.
Take corrective actions from your mobile device.
http://pubads.g.doubleclick.net/gampad/clk?id=154624111&iu=/4140/ostg.clktrk
_______________________________________________
Openwsman-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openwsman-devel